Commit eb293df7 authored by Elena Grandi's avatar Elena Grandi
Browse files

Remove nscd and install unscd instead.

parent 7c0174bd
......@@ -28,6 +28,11 @@
purge: yes
name: nslcd,libnss-ldapd
when: ldap_server is defined and ldap_base is defined
- name: Remove nscd so that later we can install unscd
apt:
name: nscd
state: absent
purge: yes
- name: Preseed libnss-ldapd for NSS switch service to configure
debconf:
name: libnss-ldapd
......@@ -59,6 +64,9 @@
- name: Install ldap packages
include: "{{includes}}/install-package-apt.yml"
with_items:
# we install unscd first so that it provides nscd as required by the
# dependency chain of nslcd
- unscd
- nslcd,libpam-ldapd,libnss-ldapd
when: ldap_server is defined and ldap_base is defined
- name: Configure nslcd
......
fuss-client (10.0.18) unstable; urgency=medium
* Remove nscd and install unscd instead.
-- Elena Grandi <elena@truelite.it> Mon, 02 Nov 2020 11:51:00 +0100
fuss-client (10.0.17) unstable; urgency=medium
* Add options to use either slick-greeter or lightdm-gtk-greeter.
......
......@@ -41,6 +41,7 @@ Depends:
libpam-ldapd,
libnss-ldapd,
nfs-common,
unscd,
nslcd,
openssl,
octofuss-client,
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment